Denial of service in Qt

Published: 2019-11-02
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2019-18281
CWE ID CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software Qt Subscribe
Vendor Trolltech

Security Advisory

This security advisory describes one low risk vulnerability.

1) Out-of-bounds read

Severity: Low

CVSSv3: 3.8 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-18281

CWE-ID: CWE-125 - Out-of-bounds Read

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary condition within the generateDirectionalRuns() function in qtextengine.cpp in Qt qtbase. A remote attacker can create a specially crafted file, containing many directional characters, trick the victim into opening it, trigger out-of-bounds read error and crash the affected application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Qt: 5.11.0, 5.11.1, 5.11.2, 5.11.3, 5.12.0, 5.12.1, 5.12.2, 5.12.3, 5.12.4

CPE External links

https://bugreports.qt.io/browse/QTBUG-77819
https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1848784
https://codereview.qt-project.org/c/qt/qtbase/+/271889

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.