Denial of service in tnef

Published: 2019-11-11 | Updated: 2019-11-11
Severity Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2019-18849
CWE ID CWE-126
Exploitation vector Network
Public exploit N/A
Vulnerable software tnef Subscribe
Vendor verdammelt

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Buffer Over-read

Severity: Medium

CVSSv3: 5.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2019-18849

CWE-ID: CWE-126 - Buffer Over-read

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to the heap-based buffer over-read involving strdup. A remote attacker can write to the victim's ".ssh/authorized_keys" file via an e-mail message with a crafted winmail.dat application/ms-tnef attachment and crash the application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

tnef: 1.4.10, 1.4.11, 1.4.12, 1.4.13, 1.4.14, 1.4.15, 1.4.16, 1.4.17

CPE External links

https://github.com/verdammelt/tnef/compare/1.4.17...1.4.18
https://github.com/verdammelt/tnef/pull/40

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.