Denial of service in Lenovo ThinkPad USB-C Dock



Published: 2019-11-20
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2019-6176
CWE-ID CWE-20
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
ThinkPad USB-C Dock
Hardware solutions / Firmware

Vendor Lenovo

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Input validation error

EUVDB-ID: #VU22862

Risk: Low

CVSSv3.1: 5.4 [CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-6176

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a local attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of user-supplied input. A local attacker can exploit this vulnerability to cause a denial of service condition on the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

ThinkPad USB-C Dock: 3.7.2


CPE2.3 External links

http://support.lenovo.com/solutions/LEN-27886

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###