Cross-Site Scripting in iobroker.web nmp package

Published: 2019-12-03 | Updated: 2019-12-03
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2019-10771
CWE ID CWE-79
Exploitation vector Network
Public exploit N/A
Vulnerable software iobroker.web Subscribe
Vendor ldittmar

Security Advisory

This security advisory describes one low risk vulnerability.

1) Cross-site scripting

Severity: Low

CVSSv3: 5.3 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2019-10771

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

iobroker.web: 0.1.7, 0.1.8, 0.1.9, 0.1.10, 0.1.11, 0.1.12, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4, 0.2.5, 0.2.6, 0.3.0, 0.3.1, 0.4.1, 0.4.2, 0.4.3, 1.0.0, 1.0.1, 1.0.2, 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.4.1, 1.4.2, 1.4.3, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.5.1, 1.5.3, 1.7.0, 1.7.1, 1.7.2, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 2.0.0, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.1.3, 2.1.4, 2.1.6, 2.1.7, 2.1.8, 2.1.9, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.4.0, 2.4.1, 2.4.4, 2.4.5, 2.4.6, 2.4.8, 2.4.9

CPE External links

https://www.npmjs.com/advisories/1345

https://snyk.io/vuln/SNYK-JS-IOBROKERWEB-534971



Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



ImmuniWeb® AI Platform for Application Security Testing