Red Hat update for python-jinja2

Published: 2019-12-03 | Updated: 2019-12-03
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2016-10745
CWE ID CWE-200
Exploitation vector Network
Public exploit N/A
Vulnerable software Red Hat Enterprise Linux for x86_64 Subscribe
Red Hat Enterprise Linux Server
Vendor Red Hat Inc.

Security Advisory

This security advisory describes one low risk vulnerability.

1) Information disclosure

Severity: Low

CVSSv3: 3.2 [CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2016-10745

CWE-ID: CWE-200 - Information Exposure

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to information disclosure in str.format in Pallets Jinja. A remote attacker can gain unauthorized access to sensitive information and use it to escape sandbox.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Red Hat Enterprise Linux for x86_64: 7.4, 7.7

Red Hat Enterprise Linux Server: 7.4, 7.7

CPE External links

https://access.redhat.com/errata/RHSA-2019:4062

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.