Session hijacking in RubyGems Rack



Published: 2019-12-19 | Updated: 2019-12-20
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2019-16782
CWE-ID CWE-208
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Rack
Web applications / Modules and components for CMS

Vendor Rack

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Information Exposure Through Timing Discrepancy

EUVDB-ID: #VU23688

Risk: Medium

CVSSv3.1: 5.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-16782

CWE-ID: CWE-208 - Information Exposure Through Timing Discrepancy

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a hijack victim's session.

The vulnerability exists due to an indexing issue in Rack (RubyGem rack) when processing user sessions. A remote attacker can guess session identifier and hijack victim's session.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Rack: 1.2.0 - 2.0.7


CPE2.3 External links

http://github.com/rack/rack/commit/7fecaee81f59926b6e1913511c90650e76673b38
http://github.com/rack/rack/security/advisories/GHSA-hrqr-hxpp-chr3

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###