Improper access control in GDPR Cookie Compliance plugin for WordPress



Published: 2019-12-27
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID N/A
CWE-ID CWE-284
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
GDPR Cookie Compliance
Web applications / Modules and components for CMS

Vendor Moove Agency

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Improper access control

EUVDB-ID: #VU23813

Risk: Medium

CVSSv3.1: 4.7 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: N/A

CWE-ID: CWE-284 - Improper Access Control

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain unauthorized access to otherwise restricted functionality.

The vulnerability exists due to improper access restrictions within the gdpr_cookie_compliance_reset_settings AJAX action. A remote authenticated user can bypass implemented security restrictions and reset authentication settings.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

GDPR Cookie Compliance: 4.0.0 - 4.0.2


CPE2.3 External links

http://wpvulndb.com/vulnerabilities/9984/
http://blog.nintechnet.com/wordpress-gdpr-cookie-compliance-plugin-fixed-authenticated-settings-deletion-vulnerability/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###