Path traversal in iobroker.js-controller NPM package



Published: 2020-01-13
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID N/A
CWE-ID CWE-22
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
iobroker.js-controller
Web applications / Modules and components for CMS

Vendor ldittmar

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Path traversal

EUVDB-ID: #VU24224

Risk: Medium

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to input validation error when processing directory traversal sequences. A remote attacker can send a specially crafted HTTP request and read arbitrary files on the system.

Mitigation

Update to version 2.0.25.

Vulnerable software versions

iobroker.js-controller: 0.3.1 - 1.5.14


CPE2.3 External links

http://www.npmjs.com/advisories/1419

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###