Multiple vulnerabilities in PostgreSQL



Published: 2020-01-27 | Updated: 2020-07-17
Risk High
Patch available YES
Number of vulnerabilities 4
CVE-ID CVE-2014-8161
CVE-2015-0241
CVE-2015-0243
CVE-2015-0244
CWE-ID CWE-209
CWE-94
CWE-89
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
PostgreSQL
Server applications / Database software

Vendor PostgreSQL Global Development Group

Security Bulletin

This security bulletin contains information about 4 vulnerabilities.

1) Information Exposure Through an Error Message

EUVDB-ID: #VU30418

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2014-8161

CWE-ID: CWE-209 - Information Exposure Through an Error Message

Exploit availability: No

Description

The vulnerability allows a remote authenticated user to gain access to sensitive information.

PostgreSQL before 9.0.19, 9.1.x before 9.1.15, 9.2.x before 9.2.10, 9.3.x before 9.3.6, and 9.4.x before 9.4.1 allows remote authenticated users to obtain sensitive column values by triggering constraint violation and then reading the error message.

Mitigation

Install update from vendor's website.

Vulnerable software versions

PostgreSQL: 9.4.0


CPE2.3 External links

http://www.debian.org/security/2015/dsa-3155
http://www.postgresql.org/about/news/1569/
http://www.postgresql.org/docs/9.4/static/release-9-4-1.html
http://www.postgresql.org/docs/current/static/release-9-0-19.html
http://www.postgresql.org/docs/current/static/release-9-1-15.html
http://www.postgresql.org/docs/current/static/release-9-2-10.html
http://www.postgresql.org/docs/current/static/release-9-3-6.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

2) Code Injection

EUVDB-ID: #VU30420

Risk: High

CVSSv3.1:

CVE-ID: CVE-2015-0241

CWE-ID: CWE-94 - Improper Control of Generation of Code ('Code Injection')

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to improper input validation in a (1) large number of digits when processing a numeric formatting template, which triggers a buffer over-read, or (2) crafted timestamp formatting template, which triggers a buffer overflow. A remote attacker can send a specially crafted request and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Update to version 9.4.1.

Vulnerable software versions

PostgreSQL: 9.4.0


CPE2.3 External links

http://www.debian.org/security/2015/dsa-3155
http://www.postgresql.org/about/news/1569/
http://www.postgresql.org/docs/9.4/static/release-9-4-1.html
http://www.postgresql.org/docs/current/static/release-9-0-19.html
http://www.postgresql.org/docs/current/static/release-9-1-15.html
http://www.postgresql.org/docs/current/static/release-9-2-10.html
http://www.postgresql.org/docs/current/static/release-9-3-6.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

3) Code Injection

EUVDB-ID: #VU30421

Risk: High

CVSSv3.1:

CVE-ID: CVE-2015-0243

CWE-ID: CWE-94 - Improper Control of Generation of Code ('Code Injection')

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to improper input validation in unspecified vectors. A remote attacker can send a specially crafted request and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Update to version 9.4.1.

Vulnerable software versions

PostgreSQL: 9.4.0


CPE2.3 External links

http://www.debian.org/security/2015/dsa-3155
http://www.postgresql.org/about/news/1569/
http://www.postgresql.org/docs/9.4/static/release-9-4-1.html
http://www.postgresql.org/docs/current/static/release-9-0-19.html
http://www.postgresql.org/docs/current/static/release-9-1-15.html
http://www.postgresql.org/docs/current/static/release-9-2-10.html
http://www.postgresql.org/docs/current/static/release-9-3-6.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?

4) SQL injection

EUVDB-ID: #VU30422

Risk: High

CVSSv3.1:

CVE-ID: CVE-2015-0244

CWE-ID: CWE-89 - Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary SQL queries in database.

The vulnerability exists due to insufficient sanitization of user-supplied data. A remote attacker can send a specially crafted request to the affected application and execute arbitrary SQL commands within the application database.

Successful exploitation of this vulnerability may allow a remote attacker to read, delete, modify data in database and gain complete control over the affected application.

Mitigation

Update to version 9.4.1.

Vulnerable software versions

PostgreSQL: 9.4.0


CPE2.3 External links

http://www.debian.org/security/2015/dsa-3155
http://www.postgresql.org/about/news/1569/
http://www.postgresql.org/docs/9.4/static/release-9-4-1.html
http://www.postgresql.org/docs/current/static/release-9-0-19.html
http://www.postgresql.org/docs/current/static/release-9-1-15.html
http://www.postgresql.org/docs/current/static/release-9-2-10.html
http://www.postgresql.org/docs/current/static/release-9-3-6.html

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###