Privilege escalation in cordova-plugin-inappbrowser package for NPM



Published: 2020-01-31
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2019-0219
CWE-ID CWE-79
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
cordova-plugin-inappbrowser
Web applications / Modules and components for CMS

Vendor surajpindoria

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Cross-site scripting

EUVDB-ID: #VU24399

Risk: Low

CVSSv3.1:

CVE-ID: CVE-2019-0219

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data passed via a specially crafted gap-iab: URI. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary JavaScript code in the main application's webview on the Android device.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Upgrade to version 3.1.0 or later.

Vulnerable software versions

cordova-plugin-inappbrowser: 0.0.1 - 3.0.0


CPE2.3 External links

http://www.npmjs.com/advisories/1467

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###