Denial of service in ClamAV DLP module



Published: 2020-02-06
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2020-3123
CWE-ID CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
ClamAV
Client/Desktop applications / Antivirus software/Personal firewalls

Vendor ClamAV

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Out-of-bounds read

EUVDB-ID: #VU25015

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-3123

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary condition in the Data-Loss-Prevention (DLP) module in Clam AntiVirus (ClamAV) with enabled optional DLP feature. A remote attacker can send a specially crafted email to the affected system, trigger an out-of-bounds read error and crash the ClamAV process.

Mitigation

Install update from vendor's website.

Vulnerable software versions

ClamAV: 0.102.0 - 0.102.1


CPE2.3 External links

http://blog.clamav.net/2020/02/clamav-01022-security-patch-released.html
http://quickview.cloudapps.cisco.com/quickview/bug/CSCvs59062

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###