Arch Linux update for dovecot



Published: 2020-02-13
Severity High
Patch available YES
Number of vulnerabilities 2
CVE ID CVE-2020-7046
CVE-2020-7957
CWE ID CWE-835
CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Arch Linux
Operating systems & Components / Operating system

Vendor Arch Linux

Security Advisory

1) Infinite loop

Severity: High

CVSSv3: 7.5 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-7046

CWE-ID: CWE-835 - Loop with Unreachable Exit Condition ('Infinite Loop')

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to infinite loop in lib-smtp in submission-login and lmtp and processing truncated UTF-8 data in command parameters. A remote non-authenticated attacker can send specially crafted command to the dovecot server and consume all available system resources and perform a denial of service attack.

Mitigation

Update the affected package dovecot to version 2.3.9.3-1.

Vulnerable software versions

Arch Linux: -

CPE External links

https://security.archlinux.org/advisory/ASA-202002-6

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Input validation error

Severity: Medium

CVSSv3: 4.6 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-7957

CWE-ID: CWE-20 - Improper Input Validation

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of user-supplied input within the IMAP and LMTP components when many characters must be read while computing the snippet and a trailing ">" character is present. As a result the recipient cannot read all messages in the mailbox.

Mitigation

Update the affected package dovecot to version 2.3.9.3-1.

Vulnerable software versions

Arch Linux: -

CPE External links

https://security.archlinux.org/advisory/ASA-202002-6

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.