Debian update for postgresql-11



Published: 2020-02-14
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2020-1720
CWE ID CWE-285
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
postgresql-11 (Debian package)
Operating systems & Components / Operating system package or component

Vendor Debian

Security Advisory

This security advisory describes one low risk vulnerability.

1) Improper Authorization

Severity: Low

CVSSv3: 3.8 [CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-1720

CWE-ID: CWE-285 - Improper Authorization

Description

The vulnerability allows a remote attacker to perform unauthorized modification of data in database.

The vulnerability exists due to the ALTER ... DEPENDS ON EXTENSION sub-commands do not perform authorization checks, which can allow an unprivileged user to drop any function, procedure, materialized view, index, or trigger under certain conditions. This attack is possible if an administrator has installed an extension and an unprivileged user can CREATE, or an extension owner either executes DROP EXTENSION predictably or can be convinced to execute DROP EXTENSION.

Mitigation

Update the affected package to version: 11.7-0+deb10u1.

Vulnerable software versions

postgresql-11 (Debian package): 11.0-1, 11.1-1, 11.1-2, 11.2-1, 11.2-2, 11.3-1, 11.4-1, 11.5-1, 11.5-1+deb10u1, 11.5-2, 11.5-3sid1, 11.5-3sid2, 11.6-0+deb10u1, 11.6-2~sid1

CPE External links

https://www.debian.org/security/2020/dsa-4623

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.