Ubuntu update for Firefox



Published: 2020-02-14
Severity High
Patch available YES
Number of vulnerabilities 4
CVE ID CVE-2020-6801
CVE-2020-6800
CVE-2020-6798
CVE-2020-6796
CWE ID CWE-119
CWE-94
CWE-787
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
firefox (Ubuntu package)
Operating systems & Components / Operating system package or component

Vendor Canonical Ltd.

Security Advisory

1) Buffer overflow

Severity: High

CVSSv3: 7.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-6801

CWE-ID: CWE-119 - Improper Restriction of Operations within the Bounds of a Memory Buffer

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when HTML content. A remote attacker can create a specially crafted website, trick the victim into opening it, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Update the affected packages.

Ubuntu 19.10
firefox - 73.0+build3-0ubuntu0.19.10.1
Ubuntu 18.04 LTS
firefox - 73.0+build3-0ubuntu0.18.04.1

Vulnerable software versions

firefox (Ubuntu package): 60.0.1+build2-0ubuntu0.18.04.1, 60.0.2+build1-0ubuntu0.18.04.1, 61.0+build3-0ubuntu0.18.04.1, 61.0.1+build1-0ubuntu0.18.04.1, 62.0.3+build1-0ubuntu0.18.04.1, 63.0+build1-0ubuntu0.18.04.1, 63.0+build2-0ubuntu0.18.04.1, 63.0.1+build4-0ubuntu0.18.04.1, 63.0.1+build4.1-0ubuntu0.18.04.1, 63.0.3+build1-0ubuntu0.18.04.1, 64.0+build1-0ubuntu0.18.04.1, 64.0+build3-0ubuntu0.18.04.1, 64.0.2+build1-0ubuntu0.18.04.1, 65.0+build2-0ubuntu0.18.04.1, 65.0.1+build2-0ubuntu0.18.04.1, 65.0.2+build1-0ubuntu0.18.04.1, 66.0+build3-0ubuntu0.18.04.1, 66.0.1+build1-0ubuntu0.18.04.1, 66.0.2+build1-0ubuntu0.18.04.1, 66.0.3+build1-0ubuntu0.18.04.1, 66.0.4+build3-0ubuntu0.18.04.1, 66.0.5+build1-0ubuntu0.18.04.1, 67.0+build1-0ubuntu0.18.04.1, 67.0+build2-0ubuntu0.18.04.1, 67.0.1+build1-0ubuntu0.18.04.1, 67.0.2+build1-0ubuntu0.18.04.1, 67.0.2+build2-0ubuntu0.18.04.1, 67.0.3+build1-0ubuntu0.18.04.1, 67.0.4+build1-0ubuntu0.18.04.1, 68.0+build1-0ubuntu0.18.04.1, 68.0+build2-0ubuntu0.18.04.1, 68.0+build3-0ubuntu0.18.04.1, 68.0.1+build1-0ubuntu0.18.04.1, 68.0.2+build1-0ubuntu0.18.04.1, 69.0+build2-0ubuntu0.18.04.1, 69.0.1+build1-0ubuntu0.18.04.1, 69.0.2+build1-0ubuntu0.18.04.1, 69.0.3+build1-0ubuntu0.18.04.1, 70.0+build2-0ubuntu0.18.04.1, 70.0+build2-0ubuntu0.19.10.1, 70.0.1+build1-0ubuntu0.18.04.1, 70.0.1+build1-0ubuntu0.19.10.1, 71.0+build2-0ubuntu0.18.04.1, 71.0+build2-0ubuntu0.19.10.1, 71.0+build5-0ubuntu0.18.04.1, 71.0+build5-0ubuntu0.19.10.1, 72.0+build4-0ubuntu0.18.04.1, 72.0+build4-0ubuntu0.19.10.1, 72.0.1+build1-0ubuntu0.18.04.1, 72.0.1+build1-0ubuntu0.19.10.1, 72.0.2+build1-0ubuntu0.18.04.1, 72.0.2+build1-0ubuntu0.19.10.1

CPE External links

https://usn.ubuntu.com/4278-1/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Memory corruption

Severity: High

CVSSv3: 7.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-6800

CWE-ID: CWE-119 - Improper Restriction of Operations within the Bounds of a Memory Buffer

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when processing HTML content. A remote attacker can create a specially crafted website, trick the victim into opening it, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Update the affected packages.

Ubuntu 19.10
firefox - 73.0+build3-0ubuntu0.19.10.1
Ubuntu 18.04 LTS
firefox - 73.0+build3-0ubuntu0.18.04.1

Vulnerable software versions

firefox (Ubuntu package): 60.0.1+build2-0ubuntu0.18.04.1, 60.0.2+build1-0ubuntu0.18.04.1, 61.0+build3-0ubuntu0.18.04.1, 61.0.1+build1-0ubuntu0.18.04.1, 62.0.3+build1-0ubuntu0.18.04.1, 63.0+build1-0ubuntu0.18.04.1, 63.0+build2-0ubuntu0.18.04.1, 63.0.1+build4-0ubuntu0.18.04.1, 63.0.1+build4.1-0ubuntu0.18.04.1, 63.0.3+build1-0ubuntu0.18.04.1, 64.0+build1-0ubuntu0.18.04.1, 64.0+build3-0ubuntu0.18.04.1, 64.0.2+build1-0ubuntu0.18.04.1, 65.0+build2-0ubuntu0.18.04.1, 65.0.1+build2-0ubuntu0.18.04.1, 65.0.2+build1-0ubuntu0.18.04.1, 66.0+build3-0ubuntu0.18.04.1, 66.0.1+build1-0ubuntu0.18.04.1, 66.0.2+build1-0ubuntu0.18.04.1, 66.0.3+build1-0ubuntu0.18.04.1, 66.0.4+build3-0ubuntu0.18.04.1, 66.0.5+build1-0ubuntu0.18.04.1, 67.0+build1-0ubuntu0.18.04.1, 67.0+build2-0ubuntu0.18.04.1, 67.0.1+build1-0ubuntu0.18.04.1, 67.0.2+build1-0ubuntu0.18.04.1, 67.0.2+build2-0ubuntu0.18.04.1, 67.0.3+build1-0ubuntu0.18.04.1, 67.0.4+build1-0ubuntu0.18.04.1, 68.0+build1-0ubuntu0.18.04.1, 68.0+build2-0ubuntu0.18.04.1, 68.0+build3-0ubuntu0.18.04.1, 68.0.1+build1-0ubuntu0.18.04.1, 68.0.2+build1-0ubuntu0.18.04.1, 69.0+build2-0ubuntu0.18.04.1, 69.0.1+build1-0ubuntu0.18.04.1, 69.0.2+build1-0ubuntu0.18.04.1, 69.0.3+build1-0ubuntu0.18.04.1, 70.0+build2-0ubuntu0.18.04.1, 70.0+build2-0ubuntu0.19.10.1, 70.0.1+build1-0ubuntu0.18.04.1, 70.0.1+build1-0ubuntu0.19.10.1, 71.0+build2-0ubuntu0.18.04.1, 71.0+build2-0ubuntu0.19.10.1, 71.0+build5-0ubuntu0.18.04.1, 71.0+build5-0ubuntu0.19.10.1, 72.0+build4-0ubuntu0.18.04.1, 72.0+build4-0ubuntu0.19.10.1, 72.0.1+build1-0ubuntu0.18.04.1, 72.0.1+build1-0ubuntu0.19.10.1, 72.0.2+build1-0ubuntu0.18.04.1, 72.0.2+build1-0ubuntu0.19.10.1

CPE External links

https://usn.ubuntu.com/4278-1/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Code Injection

Severity: Medium

CVSSv3: 4.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-6798

CWE-ID: CWE-94 - Improper Control of Generation of Code ('Code Injection')

Description

The vulnerability allows a remote attacker to execute arbitrary JavaScript code on the target system.

The vulnerability exists due to improper input validation when parsing template tag. A remote attacker can confuse the JavaScript parser into executing an arbitrary JavaScript send a specially crafted request and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Update the affected packages.

Ubuntu 19.10
firefox - 73.0+build3-0ubuntu0.19.10.1
Ubuntu 18.04 LTS
firefox - 73.0+build3-0ubuntu0.18.04.1

Vulnerable software versions

firefox (Ubuntu package): 60.0.1+build2-0ubuntu0.18.04.1, 60.0.2+build1-0ubuntu0.18.04.1, 61.0+build3-0ubuntu0.18.04.1, 61.0.1+build1-0ubuntu0.18.04.1, 62.0.3+build1-0ubuntu0.18.04.1, 63.0+build1-0ubuntu0.18.04.1, 63.0+build2-0ubuntu0.18.04.1, 63.0.1+build4-0ubuntu0.18.04.1, 63.0.1+build4.1-0ubuntu0.18.04.1, 63.0.3+build1-0ubuntu0.18.04.1, 64.0+build1-0ubuntu0.18.04.1, 64.0+build3-0ubuntu0.18.04.1, 64.0.2+build1-0ubuntu0.18.04.1, 65.0+build2-0ubuntu0.18.04.1, 65.0.1+build2-0ubuntu0.18.04.1, 65.0.2+build1-0ubuntu0.18.04.1, 66.0+build3-0ubuntu0.18.04.1, 66.0.1+build1-0ubuntu0.18.04.1, 66.0.2+build1-0ubuntu0.18.04.1, 66.0.3+build1-0ubuntu0.18.04.1, 66.0.4+build3-0ubuntu0.18.04.1, 66.0.5+build1-0ubuntu0.18.04.1, 67.0+build1-0ubuntu0.18.04.1, 67.0+build2-0ubuntu0.18.04.1, 67.0.1+build1-0ubuntu0.18.04.1, 67.0.2+build1-0ubuntu0.18.04.1, 67.0.2+build2-0ubuntu0.18.04.1, 67.0.3+build1-0ubuntu0.18.04.1, 67.0.4+build1-0ubuntu0.18.04.1, 68.0+build1-0ubuntu0.18.04.1, 68.0+build2-0ubuntu0.18.04.1, 68.0+build3-0ubuntu0.18.04.1, 68.0.1+build1-0ubuntu0.18.04.1, 68.0.2+build1-0ubuntu0.18.04.1, 69.0+build2-0ubuntu0.18.04.1, 69.0.1+build1-0ubuntu0.18.04.1, 69.0.2+build1-0ubuntu0.18.04.1, 69.0.3+build1-0ubuntu0.18.04.1, 70.0+build2-0ubuntu0.18.04.1, 70.0+build2-0ubuntu0.19.10.1, 70.0.1+build1-0ubuntu0.18.04.1, 70.0.1+build1-0ubuntu0.19.10.1, 71.0+build2-0ubuntu0.18.04.1, 71.0+build2-0ubuntu0.19.10.1, 71.0+build5-0ubuntu0.18.04.1, 71.0+build5-0ubuntu0.19.10.1, 72.0+build4-0ubuntu0.18.04.1, 72.0+build4-0ubuntu0.19.10.1, 72.0.1+build1-0ubuntu0.18.04.1, 72.0.1+build1-0ubuntu0.19.10.1, 72.0.2+build1-0ubuntu0.18.04.1, 72.0.2+build1-0ubuntu0.19.10.1

CPE External links

https://usn.ubuntu.com/4278-1/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

4) Out-of-bounds write

Severity: High

CVSSv3: 7.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-6796

CWE-ID: CWE-787 - Out-of-bounds Write

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when reading shared memory in the parent process. A remote attacker can create a specially crafted website, trick the victim into opening it, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Update the affected packages.

Ubuntu 19.10
firefox - 73.0+build3-0ubuntu0.19.10.1
Ubuntu 18.04 LTS
firefox - 73.0+build3-0ubuntu0.18.04.1

Vulnerable software versions

firefox (Ubuntu package): 60.0.1+build2-0ubuntu0.18.04.1, 60.0.2+build1-0ubuntu0.18.04.1, 61.0+build3-0ubuntu0.18.04.1, 61.0.1+build1-0ubuntu0.18.04.1, 62.0.3+build1-0ubuntu0.18.04.1, 63.0+build1-0ubuntu0.18.04.1, 63.0+build2-0ubuntu0.18.04.1, 63.0.1+build4-0ubuntu0.18.04.1, 63.0.1+build4.1-0ubuntu0.18.04.1, 63.0.3+build1-0ubuntu0.18.04.1, 64.0+build1-0ubuntu0.18.04.1, 64.0+build3-0ubuntu0.18.04.1, 64.0.2+build1-0ubuntu0.18.04.1, 65.0+build2-0ubuntu0.18.04.1, 65.0.1+build2-0ubuntu0.18.04.1, 65.0.2+build1-0ubuntu0.18.04.1, 66.0+build3-0ubuntu0.18.04.1, 66.0.1+build1-0ubuntu0.18.04.1, 66.0.2+build1-0ubuntu0.18.04.1, 66.0.3+build1-0ubuntu0.18.04.1, 66.0.4+build3-0ubuntu0.18.04.1, 66.0.5+build1-0ubuntu0.18.04.1, 67.0+build1-0ubuntu0.18.04.1, 67.0+build2-0ubuntu0.18.04.1, 67.0.1+build1-0ubuntu0.18.04.1, 67.0.2+build1-0ubuntu0.18.04.1, 67.0.2+build2-0ubuntu0.18.04.1, 67.0.3+build1-0ubuntu0.18.04.1, 67.0.4+build1-0ubuntu0.18.04.1, 68.0+build1-0ubuntu0.18.04.1, 68.0+build2-0ubuntu0.18.04.1, 68.0+build3-0ubuntu0.18.04.1, 68.0.1+build1-0ubuntu0.18.04.1, 68.0.2+build1-0ubuntu0.18.04.1, 69.0+build2-0ubuntu0.18.04.1, 69.0.1+build1-0ubuntu0.18.04.1, 69.0.2+build1-0ubuntu0.18.04.1, 69.0.3+build1-0ubuntu0.18.04.1, 70.0+build2-0ubuntu0.18.04.1, 70.0+build2-0ubuntu0.19.10.1, 70.0.1+build1-0ubuntu0.18.04.1, 70.0.1+build1-0ubuntu0.19.10.1, 71.0+build2-0ubuntu0.18.04.1, 71.0+build2-0ubuntu0.19.10.1, 71.0+build5-0ubuntu0.18.04.1, 71.0+build5-0ubuntu0.19.10.1, 72.0+build4-0ubuntu0.18.04.1, 72.0+build4-0ubuntu0.19.10.1, 72.0.1+build1-0ubuntu0.18.04.1, 72.0.1+build1-0ubuntu0.19.10.1, 72.0.2+build1-0ubuntu0.18.04.1, 72.0.2+build1-0ubuntu0.19.10.1

CPE External links

https://usn.ubuntu.com/4278-1/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.