CSV Injection in Export Users to CSV plugin for WordPress



Published: 2020-02-26
Risk High
Patch available NO
Number of vulnerabilities 1
CVE-ID N/A
CWE-ID CWE-94
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Export Users to CSV
Web applications / Modules and components for CMS

Vendor Boopathi Rajan

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Code Injection

EUVDB-ID: #VU25629

Risk: High

CVSSv3.1: 7.3 [CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H/E:U/RL:U/RC:C]

CVE-ID: N/A

CWE-ID: CWE-94 - Improper Control of Generation of Code ('Code Injection')

Exploit availability: No

Description

The vulnerability allows a remote attacker to inject arbitrary code into CSV files.

The vulnerability exists due to insufficient sanitization of user-supplied data when constructing CSV files. A remote authenticated attacker can inject malicious data into the contact form fields that is used later by the plugin to generate CSV files. Such files can be opened with Microsoft Excel built-in functions and utilize its functionality to execute malicious macros.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

Export Users to CSV: 1.2 - 1.4.2


CPE2.3 External links

http://wpvulndb.com/vulnerabilities/10094/
http://www.getastra.com/blog/911/plugin-exploit/csv-injection-in-export-users-to-csv-wordpress-plugin/
http://www.jinsonvarghese.com/csv-injection-in-export-users-to-csv-plugin/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###