Show vulnerabilities with patch / with exploit

Remote code execution in GraphicsMagick



Published: 2020-03-31
Severity High
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2020-10938
CWE ID CWE-190
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
GraphicsMagick
Universal components / Libraries / Libraries used by multiple products

Vendor GraphicsMagick Group

Security Advisory

This security advisory describes one high risk vulnerability.

1) Integer overflow

Severity: High

CVSSv3: 8.5 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-10938

CWE-ID: CWE-190 - Integer Overflow or Wraparound

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to integer overflow within the HuffmanDecodeImage in "magick/compress.c" file. A remote attacker can trigger integer overflow and execute arbitrary code on the target system, leading to heap-based buffer overflow.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

GraphicsMagick: 1.3.8, 1.3.9, 1.3.10, 1.3.11, 1.3.12, 1.3.13, 1.3.14, 1.3.15, 1.3.16, 1.3.17, 1.3.18, 1.3.19, 1.3.20, 1.3.21, 1.3.22, 1.3.23, 1.3.24, 1.3.25, 1.3.26, 1.3.27, 1.3.28, 1.3.29, 1.3.30, 1.3.31, 1.3.32, 1.3.33, 1.3.34

CPE External links

http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00049.html
https://sourceforge.net/p/graphicsmagick/code/ci/5b4dd7c6674140a115ec9424c8d19c6a458fac3e/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.