Use of a broken or risky cryptographic algorithm in wolfSSL



Published: 2020-04-12 | Updated: 2020-08-08
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2020-11713
CWE-ID CWE-327
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
wolfSSL
Universal components / Libraries / Libraries used by multiple products

Vendor wolfSSL

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Use of a broken or risky cryptographic algorithm

EUVDB-ID: #VU34470

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-11713

CWE-ID: CWE-327 - Use of a Broken or Risky Cryptographic Algorithm

Exploit availability: No

Description

The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.

wolfSSL 4.3.0 has mulmod code in wc_ecc_mulmod_ex in ecc.c that does not properly resist timing side-channel attacks.

Mitigation

Install update from vendor's website.

Vulnerable software versions

wolfSSL: 4.3.0


CPE2.3 External links

http://gist.github.com/pietroborrello/7c5be2d1dc15349c4ffc8671f0aad04f
http://github.com/wolfSSL/wolfssl/pull/2894/

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###