Multiple vulnerabilities in Several Huawei Products



Published: 2020-05-11 | Updated: 2020-07-16
Risk Medium
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2020-9099
CVE-2020-9101
CWE-ID CWE-287
CWE-119
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Huawei IPS Module
Server applications / IDS/IPS systems, Firewalls and proxy servers

Huawei NIP6300
Server applications / IDS/IPS systems, Firewalls and proxy servers

Huawei NIP6600
Server applications / IDS/IPS systems, Firewalls and proxy servers

Huawei NIP6800
Server applications / IDS/IPS systems, Firewalls and proxy servers

Huawei NGFW Module
Server applications / Other server solutions

Huawei Secospace USG6300
Server applications / Server solutions for antivurus protection

Huawei Secospace USG6500
Server applications / Server solutions for antivurus protection

Huawei Secospace USG6600
Server applications / Server solutions for antivurus protection

USG9500
Hardware solutions / Routers & switches, VoIP, GSM, etc

Vendor Huawei

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

Updated 16.07.2020
Added vulnerability #2

1) Improper Authentication

EUVDB-ID: #VU27673

Risk: Medium

CVSSv3.1: 5.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-9099

CWE-ID: CWE-287 - Improper Authentication

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass authentication process.

The vulnerability exists due to an error in when processing authentication requests. A remote attacker can bypass authentication process and obtain certain permissions on the target device.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei IPS Module: V500R001C00 - V500R005C20

Huawei NGFW Module: V500R001C00 - V500R005C20

Huawei NIP6300: V500R001C00 - V500R005C20

Huawei NIP6600: V500R001C00 - V500R005C20

Huawei NIP6800: V500R001C60 - V500R005C20

Huawei Secospace USG6300: V500R001C00 - V500R005C20

Huawei Secospace USG6500: V500R001C00 - V500R005C20

Huawei Secospace USG6600: V500R001C00 - V500R005C20

USG9500: V500R001C00 - V500R005C20


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200506-02-authentication-en

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Buffer overflow

EUVDB-ID: #VU30118

Risk: Low

CVSSv3.1: 5.7 [CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-9101

CWE-ID: CWE-119 - Improper Restriction of Operations within the Bounds of a Memory Buffer

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error. A remote attacker on the local network can send a specially crafted packets with specific parameter, trigger memory corruption and cause a denial of service condition on the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Huawei IPS Module: V500R005C00 - V500R005C10

Huawei NGFW Module: V500R005C00 - V500R005C10

Huawei Secospace USG6300: V500R001C30 - V500R005C10

Huawei Secospace USG6500: V500R001C30 - V500R005C10

Huawei Secospace USG6600: V500R001C30 - V500R005C10

USG9500: V500R001C30 - V500R005C10


CPE2.3 External links

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20200715-01-outofboundswrite-en

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the local network (LAN).

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###