Authorization bypass in MongoDB Server



Published: 2020-05-13
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2020-7921
CWE-ID CWE-285
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
MongoDB
Server applications / Database software

Vendor MongoDB, Inc.

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Improper Authorization

EUVDB-ID: #VU27864

Risk: Low

CVSSv3.1: 3.7 [CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-7921

CWE-ID: CWE-285 - Improper Authorization

Exploit availability: No

Description

The vulnerability allows a remote attacker to bypass implemented security restrictions.

The vulnerability exists due to incorrect serialization of internal state in the authorization subsystem in MongoDB Server. A remote attacker with valid user credentials can bypass IP whitelisting protection mechanism and gain access to the MongoDB server.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

MongoDB: 3.6.0 - 4.3.2


CPE2.3 External links

http://jira.mongodb.org/browse/SERVER-45472

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###