Brute-force attack in sorcery package



Published: 2020-05-14
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2020-11052
CWE-ID CWE-307
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
sorcery
Web applications / Modules and components for CMS

Vendor Ruby

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Improper Restriction of Excessive Authentication Attempts

EUVDB-ID: #VU27921

Risk: High

CVSSv3.1:

CVE-ID: CVE-2020-11052

CWE-ID: CWE-307 - Improper Restriction of Excessive Authentication Attempts

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to the system.

The vulnerability exists due to the authentication mechanism has no brute-force prevention. A remote attacker can launch a brute-force authentication attack and gain access to the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

sorcery: 0.1.0 - 0.14.0


CPE2.3 External links

http://github.com/Sorcery/sorcery/commit/0f116d223826895a73b12492f17486e5d54ab7a7
http://github.com/Sorcery/sorcery/issues/231
http://github.com/Sorcery/sorcery/pull/235
http://github.com/Sorcery/sorcery/security/advisories/GHSA-jc8m-cxhj-668x

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###