Show vulnerabilities with patch / with exploit

Cross-site request forgery in Delete All Comments Easily plugin for WordPress



Published: 2020-06-23
Severity Low
Patch available NO
Number of vulnerabilities 1
CVE ID N/A
CWE ID CWE-352
Exploitation vector Network
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
Delete All Comments Easily
Web applications / Modules and components for CMS

Vendor J P S

Security Advisory

This security advisory describes one low risk vulnerability.

1) Cross-site request forgery

Severity: Low

CVSSv3: 5.8 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:P/RL:U/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-352 - Cross-Site Request Forgery (CSRF)

Exploit availability: Yes [Search exploit]

Description

The vulnerability allows a remote attacker to perform cross-site request forgery attacks.

The vulnerability exists due to insufficient validation of the HTTP request origin. A remote attacker can trick the victim to visit a specially crafted web page and perform arbitrary actions on behalf of the victim on the vulnerable website, such as delete all comments from the blog.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

Delete All Comments Easily: 1.0, 1.1, 1.3

CPE External links

https://wpvulndb.com/vulnerabilities/10279/
https://medium.com/@hoanhp/0-day-story-2-delete-all-comments-easily-a854e52a7d50

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.



ImmuniWeb® AI Platform for Application Security Testing