Show vulnerabilities with patch / with exploit

Prototype Pollution in CasperJS



Published: 2020-06-24
Severity Medium
Patch available NO
Number of vulnerabilities 1
CVE ID CVE-2020-7679
CWE ID CWE-400
Exploitation vector Network
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
CasperJS
Web applications / JS libraries

Vendor casperjs.org

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Prototype Pollution

Severity: Medium

CVSSv3: 6.9 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-7679

CWE-ID: CWE-400 - Uncontrolled Resource Consumption ('Resource Exhaustion')

Exploit availability: Yes [Search exploit]

Description

The vulnerability allows a remote attacker to compromise the target system.

The vulnerability exists due to improper input validation in the "mergeObjects" utility function. A remote attacker can send a specially crafted request and add or modify properties of Object.prototype.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

CasperJS: 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6, 0.6.7, 0.6.8, 0.6.9, 0.6.10, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4

CPE External links

https://github.com/casperjs/casperjs/blob/master/modules/utils.js%23L680
https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWER-572804
https://snyk.io/vuln/SNYK-JS-CASPERJS-572803

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.



ImmuniWeb® AI Platform for Application Security Testing