Race condition in Cisco AMP for Endpoints and ClamAV



Published: 2020-06-24
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2020-3350
CWE ID CWE-362
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
Cisco AMP for Endpoints Linux Connector Software
Client/Desktop applications / Antivirus software/Personal firewalls

Cisco AMP for Endpoints Mac Connector Software
Client/Desktop applications / Antivirus software/Personal firewalls

ClamAV
Client/Desktop applications / Antivirus software/Personal firewalls

Vendor Cisco Systems, Inc
ClamAV

Security Advisory

This security advisory describes one low risk vulnerability.

1) Race condition

Risk: Low

CVSSv3.1: 4.8 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-3350

CWE-ID: CWE-362 - Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a race condition in the endpoint software. A local user can exploit the race, gain elevated privileges and delete arbitrary files on the system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Cisco AMP for Endpoints Linux Connector Software: before 1.12.4

Cisco AMP for Endpoints Mac Connector Software: before 1.12.4

ClamAV: 0.70, 0.71, 0.72, 0.73, 0.74, 0.75, 0.75.1, 0.80, 0.81, 0.82, 0.83, 0.84, 0.85, 0.85.1, 0.86, 0.86.1, 0.86.2, 0.87, 0.87.1, 0.88, 0.88.1, 0.88.2, 0.88.3, 0.88.4, 0.88.5, 0.88.6, 0.88.7, 0.90, 0.90.1, 0.91, 0.92, 0.93, 0.93.3, 0.94, 0.94.1, 0.94.2, 0.95, 0.95.1, 0.95.2, 0.95.3, 0.96, 0.96.1, 0.96.2, 0.96.3, 0.96.4, 0.96.5, 0.97, 0.97.0, 0.97.1, 0.97.2, 0.97.3, 0.97.4, 0.97.5, 0.97.6, 0.97.7, 0.97.8, 0.98, 0.98.0, 0.98.1, 0.98.2, 0.98.3, 0.98.4, 0.98.5, 0.98.6, 0.98.7, 0.99, 0.99.0, 0.99.1, 0.99.2, 0.99.3, 0.99.4, 0.100.0, 0.100.1, 0.100.2, 0.100.3, 0.101.0, 0.101.1, 0.101.2, 0.101.3, 0.101.4, 0.101.5, 0.102.0, 0.102.1, 0.102.2, 0.102.3

CPE External links

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-famp-ZEpdXy

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###