Show vulnerabilities with patch / with exploit

OpenSUSE Linux update for graphviz



Published: 2020-06-30
Severity Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2019-11023
CWE ID CWE-476
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Opensuse
Operating systems & Components / Operating system

Vendor Novell

Security Advisory

This security advisory describes one low risk vulnerability.

1) NULL pointer dereference

Severity: Low

CVSSv3: 2.7 [CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID: CVE-2019-11023

CWE-ID: CWE-476 - NULL Pointer Dereference

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a NULL pointer dreference error in the agroot() function within cgraphobj.c of the libcgraph.a. A remote attacker can pass specially crafted GraphML input to the affected application and perform a denial of service (DoS) attack.

Mitigation

Update the affected packages.

Vulnerable software versions

Opensuse: 15.2

CPE External links

https://lists.opensuse.org/opensuse-security-announce/2020-06/msg00065.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.