Show vulnerabilities with patch / with exploit

Cleartext storage of sensitive information in Jenkins HP ALM Quality Center plugin



Published: 2020-07-03
Severity Low
Patch available NO
Number of vulnerabilities 1
CVE ID CVE-2020-2218
CWE ID CWE-312
Exploitation vector Local
Public exploit Public exploit code for vulnerability #1 is available.
Vulnerable software
Subscribe
HP ALM Quality Center
Web applications / Modules and components for CMS

Vendor Jenkins

Security Advisory

This security advisory describes one low risk vulnerability.

1) Cleartext storage of sensitive information

Severity: Low

CVSSv3: 3.2 [CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N/E:P/RL:U/RC:C]

CVE-ID: CVE-2020-2218

CWE-ID: CWE-312 - Cleartext Storage of Sensitive Information

Exploit availability: Yes [Search exploit]

Description

The vulnerability allows a local user to view the password on the target system.

The vulnerability exists due to the affected software stores a password in plain text in its global configuration file "org.jenkinsci.plugins.qc.QualityCenterIntegrationRecorder.xml". A local user with access to the Jenkins master file system can obtain credentials.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

HP ALM Quality Center: 1.0.1, 1.2, 1.3, 1.4, 1.5, 1.6

CPE External links

http://www.openwall.com/lists/oss-security/2020/07/02/7
https://jenkins.io/security/advisory/2020-07-02/#SECURITY-1576

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.



ImmuniWeb® AI Platform for Application Security Testing