Information disclosure in Octopus Deploy



Published: 2020-07-06
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2020-14470
CWE-ID CWE-522
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Octopus Deploy
Server applications / Application servers

Vendor Octopus Deploy

Security Bulletin

This security bulletin contains one low risk vulnerability.

1) Insufficiently protected credentials

EUVDB-ID: #VU29538

Risk: Low

CVSSv3.1: 3.8 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-14470

CWE-ID: CWE-522 - Insufficiently Protected Credentials

Exploit availability: No

Description

The vulnerability allows a remote user to gain access to sensitive information.

The vulnerability exists in Octopus Deploy that allows an authenticated user to trigger a deployment that leaks the Helm Chart repository password.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Octopus Deploy: 2018.1.0 - 2019.12.1


CPE2.3 External links

http://github.com/OctopusDeploy/Issues/issues/6438

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###