Multiple vulnerabilities in RosarioSIS



Published: 2020-07-21
Risk Low
Patch available YES
Number of vulnerabilities 4
CVE ID CVE-2020-15721
CVE-2020-15717
CVE-2020-15716
CVE-2020-15718
CWE ID CWE-79
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
RosarioSIS
Web applications / CMS

Vendor RosarioSIS

Security Advisory

1) Cross-site scripting

Risk: Low

CVSSv3.1: 5.3 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-15721

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data in the href attributes for "AddStudents.php" and "User.php." in "modules/Custom/NotifyParents.php". A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

RosarioSIS: 1.2, 1.2.1, 1.2.2, 1.3, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.3-1, 1.4.3-2, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.4.9, 1.4.10, 1.4.11, 1.4.12, 1.4.13, 1.4.14, 2.0, 2.0 b, 2.0 b-2, 2.0 b.2, 2.0 b.3, 2.0 b2, 2.0 b3, 2.0 b4, 2.0.1, 2.0.2, 2.0.3, 2.1, 2.1.1, 2.2, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.3, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4, 2.4.1, 2.5, 2.5.1, 2.5.2, 2.5.3, 2.5.3 b, 2.5.4, 2.5.5, 2.5.6, 2.5.7, 2.5.8, 2.6, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.6.6, 2.7, 2.7 beta, 2.7.1, 2.7.2, 2.7.3, 2.7.4, 2.8, 2.8 beta, 2.8 beta2, 2.8 beta3, 2.8 beta4, 2.8.1, 2.8.2, 2.8.3, 2.8.3 bis, 2.8.4, 2.8.5, 2.8.6, 2.8.7, 2.8.8, 2.8.9, 2.8.10, 2.8.11, 2.8.12, 2.8.13, 2.8.14, 2.8.15, 2.8.16, 2.8.17, 2.8.18, 2.8.19, 2.8.20, 2.8.20 bis, 2.8.21, 2.8.22, 2.8.23, 2.8.24, 2.8.25, 2.8.26, 2.8.27, 2.9, 2.9 beta1, 2.9.1, 2.9.2, 2.9.3, 2.9.4, 2.9.5, 2.9.6, 2.9.7, 2.9.8, 2.9.9, 2.9.10, 2.9.11, 2.9.12, 2.9.13, 2.9.14, 2.9.15, 3.0, 3.0.1, 3.0.2, 3.1, 3.1.1, 3.1.2, 3.2, 3.3, 3.3 beta, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.4, 3.4.1, 3.4.2, 3.4.3, 3.5, 3.5.1, 3.5.2, 3.5.3, 3.6, 3.6 beta, 3.6.1, 3.7, 3.7 beta, 3.7.1, 3.8, 3.8 beta, 3.8 beta2, 3.9, 3.9 beta, 3.9.1, 3.9.2, 4.0, 4.0 beta, 4.0 beta2, 4.0 beta3, 4.1, 4.2, 4.2 beta, 4.3, 4.3 beta, 4.3.1, 4.3.2, 4.3.3, 4.3.4, 4.4, 4.4 beta, 4.4 beta2, 4.4.1, 4.4.2, 4.5, 4.5 beta2, 4.5.1, 4.5.2, 4.6, 4.6 beta, 4.6.1, 4.6.2, 4.7, 4.7 beta2, 4.7.1, 4.7.2, 4.8, 4.8 beta, 4.8 beta2, 4.8.1, 4.8.2, 4.8.3, 4.8.4, 4.8.5, 4.8.6, 4.9, 4.9 beta, 4.9.1, 4.9.2, 4.9.3, 4.9.4, 4.9.5, 4.9.6, 4.9.7, 4.9.8, 4.9.9, 4.9.10, 4.9.11, 5.0, 5.0 beta, 5.0 beta2, 5.0 beta3, 5.0 beta4, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.1, 5.1 beta, 5.1.1, 5.2, 5.2 beta, 5.3, 5.3 beta, 5.3.1, 5.3.2, 5.3.3, 5.3.4, 5.4, 5.4 beta, 5.4.1, 5.4.2, 5.4.3, 5.4.4, 5.4.5, 5.4.6, 5.4.7, 5.5, 5.5 beta, 5.5 beta2, 5.5 beta3, 5.5.1, 5.5.2, 5.5.3, 5.5.4, 5.6, 5.6 beta, 5.6.1, 5.6.2, 5.6.3, 5.6.4, 5.6.5, 5.7, 5.7.1, 5.7.2, 5.7.3, 5.7.4, 5.7.5, 5.7.6, 5.7.7, 5.8, 5.8 beta, 5.8 beta2, 5.8 beta3, 5.8 beta4, 5.8 beta5, 5.8.1, 5.9, 5.9 beta2, 5.9 beta3, 5.9.1, 5.9.2, 5.9.3, 5.9.4, 5.9.5, 5.9.6, 6.0, 6.0 beta, 6.1, 6.2, 6.2.1, 6.2.2, 6.2.3, 6.3, 6.4, 6.4.1, 6.4.2, 6.5, 6.5.1, 6.5.2, 6.6, 6.6.1, 6.7, 6.7.1, 6.7.2, 6.8 beta

CPE External links

https://gitlab.com/francoisjacquet/rosariosis/-/blob/mobile/CHANGES.md
https://gitlab.com/francoisjacquet/rosariosis/-/commit/c4a694860b50c4aa5c67d6568f7d0613fef1a30d
https://gitlab.com/francoisjacquet/rosariosis/-/issues/291

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Cross-site scripting

Risk: Low

CVSSv3.1: 5.3 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-15717

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data passed via the "advanced" parameter in the "Search.inc.php" script. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

RosarioSIS: 6.7.2

CPE External links

https://exchange.xforce.ibmcloud.com/vulnerabilities/184943
https://gitlab.com/francoisjacquet/rosariosis/-/blob/mobile/CHANGES.md
https://gitlab.com/francoisjacquet/rosariosis/-/commit/89ae9de732024e3a2e99262aa98b400a1aa6975a
https://gitlab.com/francoisjacquet/rosariosis/-/issues/291
https://gitlab.com/francoisjacquet/rosariosis/-/tags/v6.8-beta

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Cross-site scripting

Risk: Low

CVSSv3.1: 5.3 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-15716

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data passed via the "tab" parameter in the "Preferences.php" script. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

RosarioSIS: 6.7.2

CPE External links

https://exchange.xforce.ibmcloud.com/vulnerabilities/184942
https://gitlab.com/francoisjacquet/rosariosis/-/blob/mobile/CHANGES.md
https://gitlab.com/francoisjacquet/rosariosis/-/commit/89ae9de732024e3a2e99262aa98b400a1aa6975a
https://gitlab.com/francoisjacquet/rosariosis/-/issues/291
https://gitlab.com/francoisjacquet/rosariosis/-/tags/v6.8-beta

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

4) Cross-site scripting

Risk: Low

CVSSv3.1: 5.3 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-15718

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data passed via the "include_inactive" parameter in the "PrintSchedules.php" script. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

RosarioSIS: 6.7.2

CPE External links

https://exchange.xforce.ibmcloud.com/vulnerabilities/184944
https://gitlab.com/francoisjacquet/rosariosis/-/blob/mobile/CHANGES.md
https://gitlab.com/francoisjacquet/rosariosis/-/commit/89ae9de732024e3a2e99262aa98b400a1aa6975a
https://gitlab.com/francoisjacquet/rosariosis/-/issues/291
https://gitlab.com/francoisjacquet/rosariosis/-/tags/v6.8-beta

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###