Multiple vulnerabilities in HylaFAX+



Published: 2020-07-29 | Updated: 2020-08-05
Risk Low
Patch available YES
Number of vulnerabilities 2
CVE-ID CVE-2020-15397
CVE-2020-15396
CWE-ID CWE-269
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
HylaFAX
Client/Desktop applications / Messaging software

Vendor Hylafax.org

Security Bulletin

This security bulletin contains information about 2 vulnerabilities.

Updated 05.08.2020

Added fixed version

1) Improper Privilege Management

EUVDB-ID: #VU32880

Risk: Low

CVSSv3.1: 7.7 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-15397

CWE-ID: CWE-269 - Improper Privilege Management

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

HylaFAX+ through 7.0.2 and HylaFAX Enterprise have scripts that execute binaries from directories writable by unprivileged users (e.g., locations under /var/spool/hylafax that are writable by the uucp account). This allows these users to execute code in the context of the user calling these binaries (often root).

Mitigation

Install updates from vendor's website.

Vulnerable software versions

HylaFAX: 7.0.0 - 7.0.2


CPE2.3 External links

http://bugzilla.suse.com/show_bug.cgi?id=1173519
http://security.gentoo.org/glsa/202007-06
http://sourceforge.net/p/hylafax/HylaFAX+/2534/

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Improper Privilege Management

EUVDB-ID: #VU32879

Risk: Low

CVSSv3.1: 7.7 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2020-15396

CWE-ID: CWE-269 - Improper Privilege Management

Exploit availability: No

Description

The vulnerability allows a local user to escalate privileges on the system.

In HylaFAX+ through 7.0.2 and HylaFAX Enterprise, the faxsetup utility calls chown on files in user-owned directories. By winning a race, a local attacker could use this to escalate his privileges to root.


Mitigation

Install updates from vendor's website.

Vulnerable software versions

HylaFAX: 7.0.0 - 7.0.2


CPE2.3 External links

http://bugzilla.suse.com/show_bug.cgi?id=1173521
http://security.gentoo.org/glsa/202007-06
http://sourceforge.net/p/hylafax/HylaFAX+/2534/

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###