Show vulnerabilities with patch / with exploit

Gentoo update for libsndfile



Published: 2020-07-31
Severity Low
Patch available YES
Number of vulnerabilities 3
CVE ID CVE-2017-14245
CVE-2017-14246
CVE-2019-3832
CWE ID CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Gentoo Linux
Operating systems & Components / Operating system

Vendor Gentoo

Security Advisory

1) Out-of-bounds read

Severity: Low

CVSSv3: 5.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2017-14245

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote unautheticated attacker to cause DoS condition on the target system.

The weakness exists in the d2alaw_array() function due to improper handling of NAN and INFINITY floating-point values. A remote attacker can send a specially crafted source code, trick the victim into opening it, trigger an out-of-bounds read and cause the service to crash.

Mitigation

Update the affected packages.
media-libs/libsndfile to version:

Vulnerable software versions

Gentoo Linux: -

CPE External links

https://security.gentoo.org/
https://security.gentoo.org/glsa/202007-65

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Out-of-bounds read

Severity: Low

CVSSv3: 4.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2017-14246

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote unauthenticated attacker to cause DoS condition on the target system.

The weakness exists in the d2ulaw_array() function due to improper handling of NAN and INFINITY floating-point values. A remote attacker can send a specially crafted input, trick the victim into opening it, trigger an out-of-bounds read and service to crash.

Mitigation

Update the affected packages.
media-libs/libsndfile to version:

Vulnerable software versions

Gentoo Linux: -

CPE External links

https://security.gentoo.org/
https://security.gentoo.org/glsa/202007-65

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Out-of-bounds read

Severity: Low

CVSSv3: 2.9 [CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L/E:U/RL:U/RC:C]

CVE-ID: CVE-2019-3832

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to a boundary condition in the wav_write_header() function in wav.c file when processing media content. A remote attacker can create a specially crafted file, trick the victim into opening it, trigger out-of-bounds read error and crash the affected application.

Note: this vulnerability is a result of an unresolved issues, described in SB2018112313 (#5).

Mitigation

Update the affected packages.
media-libs/libsndfile to version:

Vulnerable software versions

Gentoo Linux: -

CPE External links

https://security.gentoo.org/
https://security.gentoo.org/glsa/202007-65

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.