Input validation error in ghostscript (Alpine package)



Published: 2020-09-16
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2020-16310
CWE ID CWE-20
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
ghostscript (Alpine package)
Operating systems & Components / Operating system package or component

Vendor Alpine Linux Development Team

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Input validation error

Risk: Medium

CVSSv3: 4.8 [CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-16310

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of user-supplied input in gdevdm24.c. A remote attacker can cause a denial of service via a crafted PDF file.

Mitigation

Install update from vendor's website.

Vulnerable software versions


ghostscript (Alpine package)

Alpine Linux 3.11
9.52-r0, 9.51-r0, 9.50-r0

Alpine Linux 3.10
9.50-r0

Alpine Linux 3.12
9.52-r0


CPE External links

https://git.alpinelinux.org/aports/commit/?id=5bb8ae555cbcb0c0d1d32a1aa4e81e00a1803508

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.