Input validation error in redis (Alpine package)



Published: 2020-09-16
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2020-14147
CWE ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
redis (Alpine package)
Operating systems & Components / Operating system package or component

Vendor Alpine Linux Development Team

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Input validation error

Risk: Medium

CVSSv3: 6.5 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-14147

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows context-dependent attackers with permission to run Lua code in a Redis session to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of user-supplied input. A remote attacker can cause a denial of service (memory corruption and application crash) or possibly bypass intended sandbox restrictions via a large number, which triggers a stack-based buffer overflow.

Mitigation

Install update from vendor's website.

Vulnerable software versions


redis (Alpine package)

Alpine Linux 3.12
5.0.8-r0, 5.0.4-r0, 5.0.9-r0


CPE External links

https://git.alpinelinux.org/aports/commit/?id=4afde10a9cce61d231ba9bd8e7ee3767ac5729cf

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.