Regular expression denial of service in npm-user-validate package for NPM



Published: 2020-10-17
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID N/A
CWE ID CWE-400
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
npm-user-validate
Web applications / Modules and components for CMS

Vendor WP Upgrader

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Resource exhaustion

Risk: Medium

CVSSv3: 6.5 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-400 - Uncontrolled Resource Consumption ('Resource Exhaustion')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to application does not properly control consumption of internal resources when processing overly long input strings beginning with @ characters. A remote attacker can trigger resource exhaustion and perform a denial of service (DoS) attack (aka REDos vulnerability).

Mitigation

Install updates from vendor's website.

Vulnerable software versions

npm-user-validate: 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.1.5, 1.0.0

CPE External links

https://www.npmjs.com/advisories/1572
https://github.com/advisories/GHSA-xgh6-85xh-479p

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



ImmuniWeb® AI Platform for Application Security Testing