Multiple vulnerabilities in WebKitGTK and WPE WebKit



Published: 2020-11-24 | Updated: 2020-12-01
Risk High
Patch available YES
Number of vulnerabilities 6
CVE-ID CVE-2020-9948
CVE-2020-9951
CVE-2020-9952
CVE-2020-9983
CVE-2020-13584
CVE-2020-13543
CWE-ID CWE-843
CWE-416
CWE-79
CWE-787
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
WPE WebKit
Server applications / Frameworks for developing and running applications

WebKitGTK+
Server applications / Frameworks for developing and running applications

Vendor WPE WebKit
WebKitGTK

Security Bulletin

This security bulletin contains information about 6 vulnerabilities.

Updated: 01.12.2020

Added vulnerability #6.

1) Type Confusion

EUVDB-ID: #VU46801

Risk: High

CVSSv3.1:

CVE-ID: CVE-2020-9948

CWE-ID: CWE-843 - Access of Resource Using Incompatible Type ('Type Confusion')

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a type confusion error in WebKit component in Apple Safari. A remote attacker can trick the victim to visit a specially crafted web page, trigger a type confusion error and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WPE WebKit: 2.19.93 - 2.30.2

WebKitGTK+: 2.0.0 - 2.30.2


CPE2.3 External links

http://support.apple.com/en-us/HT211845
http://webkitgtk.org/security/WSA-2020-0008.html

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

2) Use-after-free

EUVDB-ID: #VU46802

Risk: High

CVSSv3.1:

CVE-ID: CVE-2020-9951

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a use-after-free error within the aboutBlankURL() function in WebKit component in Apple Safari. A remote attacker can create a specially crafted web page, trick the victim into visiting it, trigger a use-after-free error and execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WPE WebKit: 2.19.93 - 2.30.2

WebKitGTK+: 2.0.0 - 2.30.2


CPE2.3 External links

http://support.apple.com/en-us/HT211845
http://www.talosintelligence.com/vulnerability_reports/TALOS-2020-1124
http://webkitgtk.org/security/WSA-2020-0008.html

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

3) Cross-site scripting

EUVDB-ID: #VU46803

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2020-9952

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data in WebKit component in Apple Safari. A remote attacker can trick the victim to open a specially crafted link and execute arbitrary HTML and script code in user's browser in context of a website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WPE WebKit: 2.19.93 - 2.28.2

WebKitGTK+: 2.0.0 - 2.29.3


CPE2.3 External links

http://support.apple.com/en-us/HT211845
http://webkitgtk.org/security/WSA-2020-0008.html

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

4) Out-of-bounds write

EUVDB-ID: #VU46804

Risk: High

CVSSv3.1:

CVE-ID: CVE-2020-9983

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing untrusted input in WebKit component in Apple Safari. A remote attacker can create a specially crafted website, trick the victim into opening it, trigger out-of-bounds write and execute arbitrary code on the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WPE WebKit: 2.19.93 - 2.30.2

WebKitGTK+: 2.0.0 - 2.30.2


CPE2.3 External links

http://support.apple.com/en-us/HT211845
http://webkitgtk.org/security/WSA-2020-0008.html

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

5) Use-after-free

EUVDB-ID: #VU48617

Risk: High

CVSSv3.1:

CVE-ID: CVE-2020-13584

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a use-after-free error when processing HTML content. A remote attacker can trick the victim to visit a specially crafted website, trigger a use-after-free error and execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WebKitGTK+: 2.0.0 - 2.30.2

WPE WebKit: 2.19.93 - 2.30.2


CPE2.3 External links

http://webkitgtk.org/security/WSA-2020-0008.html

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?

6) Use-after-free

EUVDB-ID: #VU48720

Risk: High

CVSSv3.1:

CVE-ID: CVE-2020-13543

CWE-ID: CWE-416 - Use After Free

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a use-after-free error when processing HTML content. A remote attacker can create a specially crafted web page, trick the victim into opening it, trigger a use-after-free error  and execute arbitrary code on the system.

Successful exploitation of the vulnerability may allow an attacker to compromise vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WebKitGTK+: 2.30.0 - 2.30.2

WPE WebKit: 2.30.0 - 2.30.2


CPE2.3 External links

http://webkitgtk.org/security/WSA-2020-0009.html

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###