Open redirect in Sentry



Published: 2021-01-11
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID N/A
CWE ID CWE-601
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
sentry
Other software / Other software solutions

Vendor Sentry

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Open redirect

Risk: Medium

CVSSv3.1: 4.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-601 - URL Redirection to Untrusted Site ('Open Redirect')

Exploit availability: No

Description

The vulnerability allows a remote attacker to redirect victims to arbitrary URL.

The vulnerability exists due to improper sanitization of user-supplied data in the "API Applications" feature. A remote attacker can create a link that leads to a trusted website, however, when clicked, redirects the victim to arbitrary domain.

Successful exploitation of this vulnerability may allow a remote attacker to perform a phishing attack and steal potentially sensitive information.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

sentry: 1.5.1, 1.6.0, 1.6.2, 1.6.4, 1.6.5, 1.6.7, 1.6.8, 1.6.8.1, 1.6.8.2, 1.7.3, 1.8.3.1, 1.8.4, 1.8.4.1, 1.8.4.2, 1.8.8, 1.10.0, 1.10.1, 1.11.0, 1.11.1, 1.11.2, 1.11.3, 1.11.4, 1.12.0, 1.12.1, 1.12.2, 1.13.0, 1.13.1, 1.13.2, 1.13.3, 1.13.4, 1.13.5, 7.7.1, 7.7.2, 7.7.3, 7.7.4, 8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.1.1, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.2.0, 8.2.1, 8.2.2, 8.2.3, 8.2.4, 8.2.5, 8.3.0, 8.3.1, 8.3.2, 8.3.3, 8.4.0, 8.4.1, 8.5.0, 8.5.1, 8.6.0, 8.7.0, 8.8.0, 8.9.0, 8.10.0, 8.11.0, 8.12.0, 8.13.0, 8.14.0, 8.14.1, 8.15.0, 8.16.0, 8.16.1, 8.17.0, 8.18.0, 8.19.0, 8.20.0, 8.21.0, 8.22.0, 9.0.0, 9.1.0, 9.1.1, 9.1.2, 10.0.0, 10.0.1, 20.6.0, 20.7.0, 20.7.1, 20.7.2, 20.8.0, 20.9.0, 20.10.0, 20.10.1, 20.11.0, 20.11.1, 20.12.0

CPE External links

https://snyk.io/vuln/SNYK-PYTHON-SENTRY-1049561
https://github.com/getsentry/sentry/pull/22547
https://hackerone.com/reports/26962

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###