Denial of service in GNU C Library



Published: 2021-01-19
Risk Medium
Patch available NO
Number of vulnerabilities 1
CVE ID CVE-2020-29562
CWE ID CWE-617
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Glibc
Universal components / Libraries / Libraries used by multiple products

Vendor GNU

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Reachable Assertion

Risk: Medium

CVSSv3: 6 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-29562

CWE-ID: CWE-617 - Reachable Assertion

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a reachable assertion when converting UCS4 text containing an irreversible character in the iconv function in the GNU C Library (aka glibc or libc6). A remote attacker can pass specially crafted data to the library, trigger an assertion failure and preform a denial of service attack.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

Glibc: 2.30, 2.30.9000, 2.31, 2.31.9000, 2.32, 2.32.9000

CPE External links

https://sourceware.org/bugzilla/show_bug.cgi?id=26923

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###