Gentoo update for Mutt



Published: 2021-01-26
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2021-3181
CWE ID CWE-400
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Gentoo Linux
Operating systems & Components / Operating system

Vendor Gentoo

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Resource exhaustion

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2021-3181

CWE-ID: CWE-400 - Uncontrolled Resource Consumption ('Resource Exhaustion')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to improper input validation when handling email messages with sequences of semicolon characters in RFC822 address fields. A remote attacker can send a specially crafted email message, force the application to consume a huge amount of memory and perform a denial of service (DoS) attack.

Mitigation

Update the affected packages.
mail-client/mutt to version: 2.0.4-r1

Vulnerable software versions

Gentoo Linux: All versions

CPE External links

https://security.gentoo.org/
https://security.gentoo.org/glsa/202101-25

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###