Multiple vulnerabilities in Schneider Electric IGSS



Published: 2021-01-29
Risk High
Patch available NO
Number of vulnerabilities 6
CVE ID N/A
CWE ID CWE-787
CWE-121
CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
IGSS SCADA
Server applications / SCADA systems

Vendor Schneider Electric

Security Advisory

1) Out-of-bounds write

Risk: High

CVSSv3.1: 8.1 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:U/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing CGF files. A remote attacker can create a specially crafted CGF file, trick the victim into opening it using the affected software, trigger out-of-bounds write and execute arbitrary code on the target system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

IGSS SCADA: 2, 4.1, 5, 5.1, 6, 7, 8, 9, 10, 11, 12, 13, 13.0.0.19140, 14, 14.0.0.19120, 14.0.0.20009, 14.0.0.20247, 14.0.0.20248

CPE External links

https://www.zerodayinitiative.com/advisories/ZDI-21-091/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Stack-based buffer overflow

Risk: High

CVSSv3.1: 8.1 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:U/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-121 - Stack-based Buffer Overflow

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when processing CGF files. A remote unauthenticated attacker can create a specially crafted CGF file, trick the victim into opening it, trigger stack-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

IGSS SCADA: 2, 4.1, 5, 5.1, 6, 7, 8, 9, 10, 11, 12, 13, 13.0.0.19140, 14, 14.0.0.19120, 14.0.0.20009, 14.0.0.20247, 14.0.0.20248

CPE External links

https://www.zerodayinitiative.com/advisories/ZDI-21-092/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Stack-based buffer overflow

Risk: High

CVSSv3.1: 8.1 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:U/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-121 - Stack-based Buffer Overflow

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when processing CGF files. A remote unauthenticated attacker can create a specially crafted CGF file, trick the victim into opening it, trigger stack-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

IGSS SCADA: 2, 4.1, 5, 5.1, 6, 7, 8, 9, 10, 11, 12, 13, 13.0.0.19140, 14, 14.0.0.19120, 14.0.0.20009, 14.0.0.20247, 14.0.0.20248

CPE External links

https://www.zerodayinitiative.com/advisories/ZDI-21-093/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

4) Out-of-bounds write

Risk: High

CVSSv3.1: 8.1 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:U/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing CGF files. A remote attacker can create a specially crafted CGF file, trick the victim into opening it using the affected software, trigger out-of-bounds write and execute arbitrary code on the target system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

IGSS SCADA: 2, 4.1, 5, 5.1, 6, 7, 8, 9, 10, 11, 12, 13, 13.0.0.19140, 14, 14.0.0.19120, 14.0.0.20009, 14.0.0.20247, 14.0.0.20248

CPE External links

https://www.zerodayinitiative.com/advisories/ZDI-21-094/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

5) Out-of-bounds write

Risk: High

CVSSv3.1: 8.1 [CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:U/RC:C] [PCI]

CVE-ID: N/A

CWE-ID: CWE-787 - Out-of-bounds Write

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise vulnerable system.

The vulnerability exists due to a boundary error when processing CGF files. A remote attacker can create a specially crafted CGF file, trick the victim into opening it using the affected software, trigger out-of-bounds write and execute arbitrary code on the target system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

IGSS SCADA: 2, 4.1, 5, 5.1, 6, 7, 8, 9, 10, 11, 12, 13, 13.0.0.19140, 14, 14.0.0.19120, 14.0.0.20009, 14.0.0.20247, 14.0.0.20248

CPE External links

https://www.zerodayinitiative.com/advisories/ZDI-21-095/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

6) Out-of-bounds read

Risk: Low

CVSSv3.1: 2.9 [CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N/E:U/RL:U/RC:C]

CVE-ID: N/A

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a remote attacker to gain access to potentially sensitive information.

The vulnerability exists due to a boundary condition when processing CGF files. A remote attacker can create a specially crafted file, trick the victim into opening it, trigger out-of-bounds read error and read contents of memory on the system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

IGSS SCADA: 2, 4.1, 5, 5.1, 6, 7, 8, 9, 10, 11, 12, 13, 13.0.0.19140, 14, 14.0.0.19120, 14.0.0.20009, 14.0.0.20247, 14.0.0.20248

CPE External links

https://www.zerodayinitiative.com/advisories/ZDI-21-096/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

How the attacker can exploit this vulnerability?

The attacker would have to send a specially crafted request to the affected application in order to exploit this vulnerability.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###