Embedded malicious code (backdoor) in http-proxy-middelware package for NPM



Published: 2021-02-03 | Updated: 2021-02-11
Risk High
Patch available NO
Number of vulnerabilities 1
CVE-ID N/A
CWE-ID CWE-506
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
http-proxy-middelware
Web applications / Modules and components for CMS

Vendor Brian C

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Embedded malicious code (backdoor)

EUVDB-ID: #VU50298

Risk: High

CVSSv3.1:

CVE-ID: N/A

CWE-ID: CWE-506 - Embedded Malicious Code

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the affected system.

The vulnerability exists due to presence of embedded malicious functionality in the application code (aka backdoor). A remote attacker can gain compromise the affected system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

http-proxy-middelware: 2.9.0


CPE2.3 External links

http://www.npmjs.com/advisories/1599

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###