Use of insufficiently random values in uIP and Contiki-OS



Published: 2021-02-10
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2020-27634
CWE ID CWE-330
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
uIP
Server applications / Other server solutions

Contiki OS
Operating systems & Components / Operating system

Vendor Adam Dunkels
contiki-os.org

Security Advisory

This security advisory describes one medium risk vulnerability.

1) Use of insufficiently random values

Risk: Medium

CVSSv3.1: 5.7 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-27634

CWE-ID: CWE-330 - Use of Insufficiently Random Values

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the target system.

The vulnerability exists due to the ISN generator is initialized with a constant value and has constant increments. A remote attacker can interfere with traffic, spoof the connection and gain access to sensitive information.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

uIP: 1.0

Contiki OS: 3.0, 4.5

CPE External links

https://www.forescout.com/company/blog/numberjack-forescout-research-labs-finds-nine-isn-generation-vulnerabilities-affecting-tcpip-stacks/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###