Multiple vulnerabilities in Secomea GateManager



Published: 2021-02-23
Risk Medium
Patch available YES
Number of vulnerabilities 2
CVE ID CVE-2020-29031
CVE-2020-29026
CWE ID CWE-264
CWE-22
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
GateManager
Server applications / Remote access servers, VPN

Vendor

Security Advisory

1) Permissions, Privileges, and Access Controls

Risk: Medium

CVSSv3: 6.2 [CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-29031

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a remote attacker to escalate privileges on the system.

The vulnerability exists due to insecure direct object reference (IDOR) issue combined with Old password check bypass. A remote authenticated attacker can gain elevated privileges and reset the password of any user in its domain or any sub-domain.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

GateManager: before 9.2c

CPE External links

https://www.secomea.com/support/cybersecurity-advisory/#2920

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Path traversal

Risk: Low

CVSSv3: 5.7 [CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2020-29026

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote user to perform directory traversal attacks.

The vulnerability exists due to input validation error when processing directory traversal sequences in the file upload function. A remote administrator can send a specially crafted HTTP request to read and write arbitrary files in the Linux file system.

Mitigation

Install update from vendor's website.

Vulnerable software versions

GateManager: before 9.2c

CPE External links

https://www.secomea.com/support/cybersecurity-advisory/#2918

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated privileged user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###