Open redirect in slashify package for npm



Published: 2021-02-23
Risk Low
Patch available NO
Number of vulnerabilities 1
CVE ID CVE-2021-3189
CWE ID CWE-601
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
slashify
Web applications / Modules and components for CMS

Vendor Divshot

Security Advisory

This security advisory describes one low risk vulnerability.

1) Open redirect

Risk: Low

CVSSv3.1: 3.1 [CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N/E:U/RL:U/RC:C]

CVE-ID: CVE-2021-3189

CWE-ID: CWE-601 - URL Redirection to Untrusted Site ('Open Redirect')

Exploit availability: No

Description

The vulnerability allows a remote attacker to redirect victims to arbitrary URL.

The vulnerability exists due to improper sanitization of user-supplied data. A remote attacker can create a link that leads to a trusted website, however, when clicked, redirects the victim to arbitrary domain.

Successful exploitation of this vulnerability may allow a remote attacker to perform a phishing attack and steal potentially sensitive information.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

slashify: 1.0.0

CPE External links

https://securitylab.github.com/advisories/GHSL-2020-199-open-redirect-slashify
https://www.npmjs.com/package/slashify
https://github.com/advisories/GHSA-f4hq-453j-p95f

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###