Arch Linux update for python-httplib2



Published: 2021-02-28
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-21240
CWE-ID CWE-400
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Arch Linux
Operating systems & Components / Operating system

Vendor Arch Linux

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Resource exhaustion

EUVDB-ID: #VU50989

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-21240

CWE-ID: CWE-400 - Resource exhaustion

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to application does not properly control consumption of internal resources. A remote attacker can trigger resource exhaustion by tricking the application to connect to a malicious server that responds with long series of "xa0" characters in the "www-authenticate" header.

Mitigation

Update the affected package python-httplib2 to version 0.19.0-1.

Vulnerable software versions

Arch Linux: All versions


CPE2.3 External links

http://security.archlinux.org/advisory/ASA-202102-35

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###