Denial of service in Etherpad



Published: 2021-03-05
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE ID N/A
CWE ID CWE-20
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Etherpad
Web applications / CMS

Vendor The Etherpad Foundation

Security Advisory

This security advisory describes one low risk vulnerability.

1) Input validation error

Risk: Low

CVSSv3.1: 3.8 [CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID: N/A

CWE-ID: CWE-20 - Improper Input Validation

Exploit availability: No

Description

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The vulnerability exists due to insufficient validation of user-supplied input when processing pad names. A remote user can pass specially crafted input to the application and cause Etherpad to restart.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Etherpad: 1.8.11

CPE External links

https://github.com/ether/etherpad-lite/releases/tag/1.8.12

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###