Buffer overflow in F5 BIG-IP TMM



Published: 2021-03-11
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-22991
CWE-ID CWE-119
Exploitation vector Network
Public exploit Vulnerability #1 is being exploited in the wild.
Vulnerable software
Subscribe
BIG-IP
Hardware solutions / Firmware

BIG-IP DDHD
Hardware solutions / Firmware

BIG-IP SSLO
Hardware solutions / Firmware

BIG-IP LTM
Hardware solutions / Security hardware applicances

BIG-IP AFM
Hardware solutions / Security hardware applicances

BIG-IP Analytics
Hardware solutions / Security hardware applicances

BIG-IP APM
Hardware solutions / Security hardware applicances

BIG-IP ASM
Hardware solutions / Security hardware applicances

BIG-IP FPS
Hardware solutions / Security hardware applicances

BIG-IP GTM
Hardware solutions / Security hardware applicances

BIG-IP PEM
Hardware solutions / Security hardware applicances

BIG-IP AAM
Hardware solutions / Routers & switches, VoIP, GSM, etc

BIG-IP DNS
Hardware solutions / Routers & switches, VoIP, GSM, etc

BIG-IP Link Controller
Hardware solutions / Routers & switches, VoIP, GSM, etc

BIG-IP Advanced WAF
Client/Desktop applications / Antivirus software/Personal firewalls

Vendor F5 Networks, Inc.

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Buffer overflow

EUVDB-ID: #VU51422

Risk: High

CVSSv3.1:

CVE-ID: CVE-2021-22991

CWE-ID: CWE-119 - Improper Restriction of Operations within the Bounds of a Memory Buffer

Exploit availability: No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error when processing HTTP requests within the Traffic Management Microkernel (TMM) URI normalization feature. A remote attacker can create a specially crafted HTTP request to the virtual server associated with an HTTP profile, trigger memory corruption and crash the service or execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

BIG-IP: 12.1.0 - 16.0.1

BIG-IP LTM: 12.1.0 - 16.0.1

BIG-IP AAM: 12.1.0 - 16.0.1

BIG-IP Advanced WAF: 12.1.0 - 16.0.1

BIG-IP AFM: 12.1.0 - 16.0.1

BIG-IP Analytics: 12.1.0 - 16.0.1

BIG-IP APM: 12.1.0 - 16.0.1

BIG-IP ASM: 12.1.0 - 16.0.1

BIG-IP DDHD: 12.1.0 - 16.0.1

BIG-IP DNS: 12.1.0 - 16.0.1

BIG-IP FPS: 12.1.0 - 16.0.1

BIG-IP GTM: 12.1.0 - 16.0.1

BIG-IP Link Controller: 12.1.0 - 16.0.1

BIG-IP PEM: 12.1.0 - 16.0.1

BIG-IP SSLO: 12.1.0 - 16.0.1


CPE2.3 External links

http://support.f5.com/csp/article/K56715231

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###