Denial of service in Cisco Firepower Threat Defense Software



Published: 2021-04-29
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-1402
CWE-ID CWE-119
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Cisco Firepower Threat Defense (FTD)
Hardware solutions / Security hardware applicances

3000 Series Industrial Security Appliance (ISA)
Server applications / IDS/IPS systems, Firewalls and proxy servers

Cisco Firepower Threat Defense Virtual (FTDv)
Server applications / IDS/IPS systems, Firewalls and proxy servers

ASA 5512-X Adaptive Security Appliance
Server applications / Other server solutions

ASA 5515-X Adaptive Security Appliance
Server applications / Other server solutions

ASA 5525-X Adaptive Security Appliance
Server applications / Other server solutions

ASA 5545-X Adaptive Security Appliance
Server applications / Other server solutions

ASA 5555-X Adaptive Security Appliance
Server applications / Other server solutions

Firepower 1000 Series Appliances
Hardware solutions / Other hardware appliances

Vendor Cisco Systems, Inc

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Buffer overflow

EUVDB-ID: #VU52742

Risk: Medium

CVSSv3.1: 6.5 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-1402

CWE-ID: CWE-119 - Improper Restriction of Operations within the Bounds of a Memory Buffer

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary error in the software-based SSL/TLS message handler. A remote attacker can send a specially crafted SSL/TLS message, trigger memory corruption and cause a denial of service condition on the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Cisco Firepower Threat Defense (FTD): 6.2.2, 6.2.3, 6.3.0

3000 Series Industrial Security Appliance (ISA): All versions

ASA 5512-X Adaptive Security Appliance: All versions

ASA 5515-X Adaptive Security Appliance: All versions

ASA 5525-X Adaptive Security Appliance: All versions

ASA 5545-X Adaptive Security Appliance: All versions

ASA 5555-X Adaptive Security Appliance: All versions

Firepower 1000 Series Appliances: All versions

Cisco Firepower Threat Defense Virtual (FTDv): All versions


CPE2.3 External links

http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-ftd-ssl-decrypt-dos-DdyLuK6c

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###