Denial of service in OPC Foundation UA Products Built with .NET Framework



Published: 2021-05-14
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-27432
CWE-ID CWE-674
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
OPC UA .NET Legacy
Server applications / Other server solutions

OPC UA .NET Standard
Server applications / Other server solutions

Vendor OPC Foundation

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Uncontrolled Recursion

EUVDB-ID: #VU53244

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-27432

CWE-ID: CWE-674 - Uncontrolled Recursion

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to an uncontrolled recursion. A remote attacker can cause a denial of service condition on the target system.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

OPC UA .NET Legacy: All versions

OPC UA .NET Standard: before 1.4.365.48


CPE2.3 External links

http://ics-cert.us-cert.gov/advisories/icsa-21-133-03

Q & A

Can this vulnerability be exploited remotely?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###