Deniall of service in QEMU



Published: 2021-06-22
Risk Medium
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-20221
CWE-ID CWE-125
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
QEMU
Client/Desktop applications / Virtualization software

Vendor QEMU

Security Bulletin

This security bulletin contains one medium risk vulnerability.

1) Out-of-bounds read

EUVDB-ID: #VU54317

Risk: Medium

CVSSv3.1:

CVE-ID: CVE-2021-20221

CWE-ID: CWE-125 - Out-of-bounds Read

Exploit availability: No

Description

The vulnerability allows a local user to perform DoS attack.

The vulnerability exists due to an out-of-bounds heap buffer access in the ARM Generic Interrupt Controller emulator of QEMU. A privileged guest user may use this flaw to crash the QEMU process on the host resulting in DoS scenario.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

QEMU: 4.0.0 - 4.2.0


CPE2.3 External links

http://lists.debian.org/debian-lts-announce/2021/02/msg00024.html
http://bugzilla.redhat.com/show_bug.cgi?id=1924601
http://www.openwall.com/lists/oss-security/2021/02/05/1

Q & A

Can this vulnerability be exploited remotely?

How the attacker can exploit this vulnerability?

Is there known malware, which exploits this vulnerability?



###SIDEBAR###