Session fixation in Craft CMS



Published: 2021-07-05
Risk High
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-27903
CWE-ID CWE-384
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Craft CMS
Web applications / CMS

Vendor Pixel & Tonic, Inc.

Security Bulletin

This security bulletin contains one high risk vulnerability.

1) Session Fixation

EUVDB-ID: #VU54557

Risk: High

CVSSv3.1: 7.1 [CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C]

CVE-ID: CVE-2021-27903

CWE-ID: CWE-384 - Session Fixation

Exploit availability: No

Description

The vulnerability allows a remote attacker to compromise the affected application.

The vulnerability exists due to session fixation issue. A remote attacker can hijack administrator's session and gain full access to the web application.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

Craft CMS: 3.6.0 - 3.6.6


CPE2.3 External links

http://github.com/craftcms/cms/blob/develop/CHANGELOG.md#367---2021-02-23
http://github.com/craftcms/cms/blob/develop/CHANGELOG.md#security
http://github.com/craftcms/cms/commit/c17728fa0bec11d3b82c34defe0930ed409aec38

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###