SQL injection in WooCommerce and WooCommerce Blocks plugin



Published: 2021-07-16 | Updated: 2021-10-27
Risk Critical
Patch available YES
Number of vulnerabilities 1
CVE-ID CVE-2021-32789
CWE-ID CWE-89
Exploitation vector Network
Public exploit This vulnerability is being exploited in the wild.
Vulnerable software
Subscribe
WooCommerce
Web applications / Modules and components for CMS

WooCommerce Blocks
Web applications / Modules and components for CMS

Vendor WooCommerce
Automattic

Security Bulletin

This security bulletin contains information about 1 vulnerabilities.

Updated 29.02.2021
Assigned CVE-ID number.

1) SQL injection

EUVDB-ID: #VU54918

Risk: Critical

CVSSv3.1: 9.4 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H/RL:O/RC:C]

CVE-ID: CVE-2021-32789

CWE-ID: CWE-89 - Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

Exploit availability: Yes

Description

The vulnerability allows a remote attacker to execute arbitrary SQL queries in database.

The vulnerability exists due to insufficient sanitization of user-supplied data. A remote attacker can send a specially crafted request to the affected application and execute arbitrary SQL commands within the application database.

Successful exploitation of this vulnerability may allow a remote attacker to read, delete, modify data in database and gain complete control over the affected application.

Note, the vulnerability is being actively exploited in the wild.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

WooCommerce: 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.5.0, 3.5.1, 3.5.2, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.6.0, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.7.0, 3.7.1, 3.8.0, 3.8.1, 3.9.0, 3.9.1, 3.9.2, 3.9.3, 4.0.0, 4.0.1, 4.1.0, 4.1.1, 4.2.0, 4.2.1, 4.2.2, 4.3.0, 4.3.1, 4.3.2, 4.3.3, 4.4.0, 4.4.1, 4.5.0, 4.5.1, 4.5.2, 4.6.0, 4.6.1, 4.6.2, 4.7.0, 4.7.1, 4.8.0, 4.9.0, 4.9.1, 4.9.2, 5.0.0, 5.1.0, 5.2.0, 5.2.1, 5.2.2, 5.3.0, 5.4.0, 5.4.1, 5.5.0

WooCommerce Blocks: 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5, 2.5.6, 2.5.7, 2.5.8, 2.5.9, 2.5.10, 2.5.11, 2.5.13, 2.5.14, 2.5.15, 2.6.0, 2.6.1, 2.7.0, 2.7.1, 2.8.0, 2.9.0, 3.0.0, 3.1.0, 3.2, 3.3.0, 3.4.0, 3.5.0, 3.6.0, 3.7.0, 3.7.1, 3.8.0, 3.9.0, 4.0.0, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.4.2, 4.5.0, 4.5.0-dev, 4.5.1, 4.5.2, 4.6.0, 4.7.0, 4.8.0, 4.9.0, 4.9.1, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.3.1, 5.4.0, 5.5.0

CPE2.3 External links

http://threatpost.com/zero-day-attacks-woocommerce-databases/167846/
http://woocommerce.com/posts/critical-vulnerability-detected-july-2021/

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

Yes. This vulnerability is being exploited in the wild.



###SIDEBAR###