Red Hat Enterprise Linux 7.3 update for kernel



Published: 2021-07-20
Risk Low
Patch available YES
Number of vulnerabilities 3
CVE-ID CVE-2017-5753
CVE-2017-5715
CVE-2017-5754
CWE-ID CWE-200
Exploitation vector Local
Public exploit Public exploit code for vulnerability #1 is available.
Public exploit code for vulnerability #2 is available.
Public exploit code for vulnerability #3 is available.
Vulnerable software
Subscribe
kernel (Red Hat package)
Operating systems & Components / Operating system package or component

Red Hat Enterprise Linux Server - Update Services for SAP Solutions
Operating systems & Components / Operating system package or component

Red Hat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions
Operating systems & Components / Operating system package or component

Red Hat Enterprise Linux Server - TUS
Operating systems & Components / Operating system

Red Hat Enterprise Linux for Power, little endian - Extended Update Support
Operating systems & Components / Operating system

Red Hat Enterprise Linux Server - AUS
Operating systems & Components / Operating system

Red Hat Enterprise Linux for Power, big endian - Extended Update Support
Operating systems & Components / Operating system

Red Hat Enterprise Linux for IBM z Systems - Extended Update Support
Operating systems & Components / Operating system

Red Hat Enterprise Linux EUS Compute Node
Operating systems & Components / Operating system

Vendor Red Hat Inc.

Security Bulletin

This security bulletin contains information about 3 vulnerabilities.

1) Information disclosure

EUVDB-ID: #VU9884

Risk: Low

CVSSv3.1: 5.9 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N/E:P/RL:O/RC:C]

CVE-ID: CVE-2017-5753

CWE-ID: CWE-200 - Information Exposure

Exploit availability: Yes

Description

The vulnerability allows a local attacker to obtain potentially sensitive information.

The vulnerability exists in Intel CPU hardware due to improper implementation of the speculative execution of instructions. A local attacker can perform a bounds check bypass, execute arbitrary code, conduct a side-channel attack and read sensitive memory information.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

kernel (Red Hat package): 3.10.0-123.1.2.el7, 3.10.0-123.4.2.el7, 3.10.0-123.4.4.el7, 3.10.0-123.6.3.el7, 3.10.0-123.8.1.el7, 3.10.0-123.9.2.el7, 3.10.0-123.13.1.el7, 3.10.0-123.13.2.el7, 3.10.0-229.20.1.el7, 3.10.0-229.24.2.el7, 3.10.0-229.26.2.el7, 3.10.0-229.38.1.el7, 3.10.0-229.40.1.el7, 3.10.0-229.42.2.el7, 3.10.0-229.46.1.el7, 3.10.0-229.48.1.el7, 3.10.0-229.49.1.el7, 3.10.0-229.el7, 3.10.0-327.3.1.el7, 3.10.0-327.4.5.el7, 3.10.0-327.10.1.el7, 3.10.0-327.18.2.el7, 3.10.0-327.22.2.el7, 3.10.0-327.28.2.el7, 3.10.0-327.28.3.el7, 3.10.0-327.36.1.el7, 3.10.0-327.36.2.el7, 3.10.0-327.36.3.el7, 3.10.0-327.41.3.el7, 3.10.0-327.46.1.el7, 3.10.0-327.49.2.el7, 3.10.0-327.53.1.el7, 3.10.0-327.55.2.el7, 3.10.0-327.58.1.el7, 3.10.0-327.59.2.el7, 3.10.0-327.59.3.el7, 3.10.0-327.61.3.el7, 3.10.0-327.62.4.el7, 3.10.0-327.66.1.el7, 3.10.0-327.66.3.el7, 3.10.0-327.66.5.el7, 3.10.0-327.71.1.el7, 3.10.0-327.71.4.el7, 3.10.0-327.73.1.el7, 3.10.0-327.76.1.el7, 3.10.0-327.78.2.el7, 3.10.0-327.79.2.el7, 3.10.0-327.82.1.el7, 3.10.0-327.82.2.el7, 3.10.0-327.83.1.el7, 3.10.0-327.85.1.el7, 3.10.0-327.86.1.el7, 3.10.0-327.88.1.el7, 3.10.0-327.89.1.el7, 3.10.0-327.90.2.el7, 3.10.0-327.93.1.el7, 3.10.0-327.96.1.el7, 3.10.0-327.el7, 3.10.0-514.6.1.el7, 3.10.0-514.6.2.el7, 3.10.0-514.10.2.el7, 3.10.0-514.16.1.el7, 3.10.0-514.21.1.el7, 3.10.0-514.21.2.el7, 3.10.0-514.26.1.el7, 3.10.0-514.28.1.el7, 3.10.0-514.28.2.el7, 3.10.0-514.32.2.el7, 3.10.0-514.32.3.el7

Red Hat Enterprise Linux Server - Update Services for SAP Solutions: 7.3

Red Hat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions: 7.3

Red Hat Enterprise Linux Server - TUS: 7.3

Red Hat Enterprise Linux for Power, little endian - Extended Update Support: 7.3

Red Hat Enterprise Linux Server - AUS: 7.3

Red Hat Enterprise Linux for Power, big endian - Extended Update Support: 7.3

Red Hat Enterprise Linux for IBM z Systems - Extended Update Support: 7.3

Red Hat Enterprise Linux EUS Compute Node: 7.3

CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:0182

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.

2) Information disclosure

EUVDB-ID: #VU9883

Risk: Low

CVSSv3.1: 5 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P/RL:O/RC:C]

CVE-ID: CVE-2017-5715

CWE-ID: CWE-200 - Information Exposure

Exploit availability: Yes

Description

The vulnerability allows a local attacker to obtain potentially sensitive information.

The vulnerability exists in Intel CPU hardware due to improper implementation of the speculative execution of instructions. A local attacker can utilize branch target injection, execute arbitrary code, perform a side-channel attack and read sensitive memory information.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

kernel (Red Hat package): 3.10.0-123.1.2.el7, 3.10.0-123.4.2.el7, 3.10.0-123.4.4.el7, 3.10.0-123.6.3.el7, 3.10.0-123.8.1.el7, 3.10.0-123.9.2.el7, 3.10.0-123.13.1.el7, 3.10.0-123.13.2.el7, 3.10.0-229.20.1.el7, 3.10.0-229.24.2.el7, 3.10.0-229.26.2.el7, 3.10.0-229.38.1.el7, 3.10.0-229.40.1.el7, 3.10.0-229.42.2.el7, 3.10.0-229.46.1.el7, 3.10.0-229.48.1.el7, 3.10.0-229.49.1.el7, 3.10.0-229.el7, 3.10.0-327.3.1.el7, 3.10.0-327.4.5.el7, 3.10.0-327.10.1.el7, 3.10.0-327.18.2.el7, 3.10.0-327.22.2.el7, 3.10.0-327.28.2.el7, 3.10.0-327.28.3.el7, 3.10.0-327.36.1.el7, 3.10.0-327.36.2.el7, 3.10.0-327.36.3.el7, 3.10.0-327.41.3.el7, 3.10.0-327.46.1.el7, 3.10.0-327.49.2.el7, 3.10.0-327.53.1.el7, 3.10.0-327.55.2.el7, 3.10.0-327.58.1.el7, 3.10.0-327.59.2.el7, 3.10.0-327.59.3.el7, 3.10.0-327.61.3.el7, 3.10.0-327.62.4.el7, 3.10.0-327.66.1.el7, 3.10.0-327.66.3.el7, 3.10.0-327.66.5.el7, 3.10.0-327.71.1.el7, 3.10.0-327.71.4.el7, 3.10.0-327.73.1.el7, 3.10.0-327.76.1.el7, 3.10.0-327.78.2.el7, 3.10.0-327.79.2.el7, 3.10.0-327.82.1.el7, 3.10.0-327.82.2.el7, 3.10.0-327.83.1.el7, 3.10.0-327.85.1.el7, 3.10.0-327.86.1.el7, 3.10.0-327.88.1.el7, 3.10.0-327.89.1.el7, 3.10.0-327.90.2.el7, 3.10.0-327.93.1.el7, 3.10.0-327.96.1.el7, 3.10.0-327.el7, 3.10.0-514.6.1.el7, 3.10.0-514.6.2.el7, 3.10.0-514.10.2.el7, 3.10.0-514.16.1.el7, 3.10.0-514.21.1.el7, 3.10.0-514.21.2.el7, 3.10.0-514.26.1.el7, 3.10.0-514.28.1.el7, 3.10.0-514.28.2.el7, 3.10.0-514.32.2.el7, 3.10.0-514.32.3.el7

Red Hat Enterprise Linux Server - Update Services for SAP Solutions: 7.3

Red Hat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions: 7.3

Red Hat Enterprise Linux Server - TUS: 7.3

Red Hat Enterprise Linux for Power, little endian - Extended Update Support: 7.3

Red Hat Enterprise Linux Server - AUS: 7.3

Red Hat Enterprise Linux for Power, big endian - Extended Update Support: 7.3

Red Hat Enterprise Linux for IBM z Systems - Extended Update Support: 7.3

Red Hat Enterprise Linux EUS Compute Node: 7.3

CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:0182

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.

3) Information disclosure

EUVDB-ID: #VU9882

Risk: Low

CVSSv3.1: 5 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P/RL:O/RC:C]

CVE-ID: CVE-2017-5754

CWE-ID: CWE-200 - Information Exposure

Exploit availability: Yes

Description

The vulnerability allows a local attacker to obtain potentially sensitive information.

The vulnerability exists in Intel CPU hardware due to side-channel attacks, which are also referred to as Meltdown attacks. A local attacker can execute arbitrary code, perform a side-channel analysis of the data cache and gain access to sensitive information including memory from the CPU cache.

Mitigation

Install updates from vendor's website.

Vulnerable software versions

kernel (Red Hat package): 3.10.0-123.1.2.el7, 3.10.0-123.4.2.el7, 3.10.0-123.4.4.el7, 3.10.0-123.6.3.el7, 3.10.0-123.8.1.el7, 3.10.0-123.9.2.el7, 3.10.0-123.13.1.el7, 3.10.0-123.13.2.el7, 3.10.0-229.20.1.el7, 3.10.0-229.24.2.el7, 3.10.0-229.26.2.el7, 3.10.0-229.38.1.el7, 3.10.0-229.40.1.el7, 3.10.0-229.42.2.el7, 3.10.0-229.46.1.el7, 3.10.0-229.48.1.el7, 3.10.0-229.49.1.el7, 3.10.0-229.el7, 3.10.0-327.3.1.el7, 3.10.0-327.4.5.el7, 3.10.0-327.10.1.el7, 3.10.0-327.18.2.el7, 3.10.0-327.22.2.el7, 3.10.0-327.28.2.el7, 3.10.0-327.28.3.el7, 3.10.0-327.36.1.el7, 3.10.0-327.36.2.el7, 3.10.0-327.36.3.el7, 3.10.0-327.41.3.el7, 3.10.0-327.46.1.el7, 3.10.0-327.49.2.el7, 3.10.0-327.53.1.el7, 3.10.0-327.55.2.el7, 3.10.0-327.58.1.el7, 3.10.0-327.59.2.el7, 3.10.0-327.59.3.el7, 3.10.0-327.61.3.el7, 3.10.0-327.62.4.el7, 3.10.0-327.66.1.el7, 3.10.0-327.66.3.el7, 3.10.0-327.66.5.el7, 3.10.0-327.71.1.el7, 3.10.0-327.71.4.el7, 3.10.0-327.73.1.el7, 3.10.0-327.76.1.el7, 3.10.0-327.78.2.el7, 3.10.0-327.79.2.el7, 3.10.0-327.82.1.el7, 3.10.0-327.82.2.el7, 3.10.0-327.83.1.el7, 3.10.0-327.85.1.el7, 3.10.0-327.86.1.el7, 3.10.0-327.88.1.el7, 3.10.0-327.89.1.el7, 3.10.0-327.90.2.el7, 3.10.0-327.93.1.el7, 3.10.0-327.96.1.el7, 3.10.0-327.el7, 3.10.0-514.6.1.el7, 3.10.0-514.6.2.el7, 3.10.0-514.10.2.el7, 3.10.0-514.16.1.el7, 3.10.0-514.21.1.el7, 3.10.0-514.21.2.el7, 3.10.0-514.26.1.el7, 3.10.0-514.28.1.el7, 3.10.0-514.28.2.el7, 3.10.0-514.32.2.el7, 3.10.0-514.32.3.el7

Red Hat Enterprise Linux Server - Update Services for SAP Solutions: 7.3

Red Hat Enterprise Linux Server (for IBM Power LE) - Update Services for SAP Solutions: 7.3

Red Hat Enterprise Linux Server - TUS: 7.3

Red Hat Enterprise Linux for Power, little endian - Extended Update Support: 7.3

Red Hat Enterprise Linux Server - AUS: 7.3

Red Hat Enterprise Linux for Power, big endian - Extended Update Support: 7.3

Red Hat Enterprise Linux for IBM z Systems - Extended Update Support: 7.3

Red Hat Enterprise Linux EUS Compute Node: 7.3

CPE2.3 External links

http://access.redhat.com/errata/RHSA-2018:0182

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability. However, proof of concept for this vulnerability is available.



###SIDEBAR###